В HTML      В PDF
микроэлектроника, микросхема, микроконтроллер, память, msp430, MSP430, Atmel, Maxim, LCD, hd44780, t6963, sed1335, SED1335, mega128, avr, mega128  
  Главная страница > Программы > HT-3000

реклама

 
радиационно стойкие ПЗУ Миландр

Продажа силового и бронированного кабеля и провода в Москве

текст еще



Глава 4. Меню - Проект (Project)

Программа HT-IDE3000 содержит пример Проекта, который может помочь новичкам в скорейшем освоении разработки проектов. Обратите внимание, что основным рабочим элементом для программы HT-IDE3000 является Проект, каждая разработка представляет собой отдельный законченный Проект. Пользователям, не имеющим опыта работы с программой HT-IDE3000, рекомендуется начать изучение процесса разработки с предыдущих глав.


Рис. 4-1

Создание нового Проекта

В меню Проект (Project) (Рис. 4-1) выберите команду Новый (New) для создания нового Проекта. При этом следует заполнить или выбрать две информационные строки о проекте - Имя Проекта (Project Name) и тип микроконтроллера (Micro Controller) (Рис. 4-2). Пользователь может сделать обзор по всем директориям и всем существующим проектам и выбрать один из них (для перезаписи старого проекта новым) а также выбрать один из типов МК.

Примечание: Имя проекта - это название файла с расширением .PRJ.


Рис. 4-2

Открытие и закрытие Проекта

Программа HT-IDE3000 может работать только с одним текущим активным проектом. Для работы над проектом, его следует открыть, используя команду Open меню Project (Рис. 4-1). После этого, заполнить имя проекта либо выбрать существующий при помощи кнопки Обзор (Browse). Для закрытия проекта используйте команду Закрыть (Close).

Примечание: При открытии проекта текущий открытый проект автоматически закрывается. В процессе разработки, т.е. во время редактирования, установки опций, отладки и т.д., обращайте внимание на то, чтобы проект находился в отрытом состоянии. В этом можно убедиться, посмотрев на имя открытого проекта в названии окна программы HT-IDE3000. В противном случае результаты могут быть утеряны. Программа HT-IDE3000 сохраняет информацию о последнем открытом проекте, если осуществить выход из программы HT-IDE3000 без закрытия проекта, при следующем запуске HT-IDE3000 проект будет открыт автоматически.

Управление исходными файлами в проекте

Для добавления или извлечения исходных файлов в текущий открытый проект используйте команду Edit. Порядок исходных файлов в списке, сверху вниз, определяет порядок использования файлов Кросс-линкером. Две кнопки, Переместить вверх [Move Up] и Переместить вниз [Move Down] используются для установления требуемого порядка исходных файлов в проекте. На Рис. 4-3 показано диалоговое окно команды редактирования Edit меню Проект (Project).


Рис. 4-3

Добавление исходного файла в проект

  • Наберите имя исходного файла в текстовой строке File Name в диалоговом меню редактирования Edit
  • Либо, если файл уже существует, выберите требуемое расширение и найдите файл
    • Выберите диск и директорию, где находятся исходные файлы с помощью кнопок навигации
    • Выберите исходный файл в окне
    • Двойной щелчок по выбранному файлу либо кнопка <Add> добавляет исходный файл в проект После того, как выбранный файл был добавлен в проект, его название появится в списке файлов проекта (Files in Project).

Удаление исходного файла из проекта

  • Выберите файл, который следует удалить из проекта
  • Нажмите кнопку <Delete>

Примечание Удаление исходных файлов из Проекта не приводит к их физическому удалению, удаляются лишь ссылки на данный файл в Проекте.

Перемещение исходного файла вверх/вниз

  • Выберите файл, который следует переместить в списке файлов Проекта (Files in Project), подведя к нему курсор и нажав кнопку мыши
  • Нажмите кнопку переместить вверх [Move Up] или переместить вниз [Move Down]

    Создание файлов задач проекта

    Перед выполнением проекта, убедитесь, что вы выполнили требуемые предыдущие шаги:

    • Проект открыт
    • Все требуемые опции проекта установлены
    • Исходные файлы добавлены в Проект
    • Установлены опции МК (см. Главу Меню Инструменты)

    Существуют две команды для выполнения проекта - Выполнить (Build) и Выполнить всё по новой (Rebuild All).

    Команда Выполнить (Build) меню Проект (Project) осуществляет следующие операции:

    • Ассемблирует либо компилирует исходный файл текущего активного проекта путём вызова Кросс-ассемблера либо компилятора C, в зависимости от расширения .asm или .C
    • Линкует все объектные файлы, сгенерированные Кросс-ассемблером или компилятором C и генерирует файл задач и файл отладки.
    • Загружает файл задач в HT-ICE, если последний доступен
    • Отображает исходную программу, начиная с её стартовой точки, в активном окне программы HT-IDE3000 ( при эмуляции программа использует исходные файлы, файл задач и файл отладки)

    Примечание: Команда Выполнить (Build) может выполнять либо не выполнять некоторые из указанных выше действий, это зависит от даты и времени создания соответствующих файлов. Осуществление этих действий подчиняется следующим правилам:

    • Если дата и время создания исходного файла позже, чем дата и время создания объектного файла, Кросс-ассемблер или компилятор языка C будет вызван, при этом исходные файлы будут скомпилированы/ассемблированы и будет создан новый объектный файл.
    • Если один из объектных файлов, входящих в состав файла задач, имеет более позднее время/дату создания, чем файл задач, будет запущен Кросс-линкер, осуществлена линковка объектных файлов и генерация нового файла задач.

    Загрузка файла задач в HT-ICE осуществляется автоматически по команде Выполнить (Build), вне зависимости от выполнения либо невыполнения предшествующих действий.

    Команда Выполнить всё по новой (Rebuild All) выполняет те же действия, что и команда Выполнить (Build). Отличие заключается в том, что команда Выполнить всё по новой (Rebuild All) осуществит весь список действий без проверки даты и времени создания файлов.

    Результат выполнения операций Выполнить (Build)и Выполнить всё по новой (Rebuild All) отображается в окне Output.

    Если в процессе выполнения этих команд возникли ошибки, дальнейшее выполнение прекращается, файл задач не генерируется и не загружается в эмулятор.

    Создание файла задач проекта

    • Выберите команду Открыть (Open) в меню Проект (Project) и откройте проект
    • Выберите команду Выполнить (Build) в меню Проект (Project) либо используйте аналогичную кнопку на панели инструментов (Рис. 4-1) для выполнения проекта

    Обновление файла задач проекта

    • Выберите команду Открыть (Open) в меню Проект (Project) и откройте проект
    • Выберите команду Выполнить всё по новой (Rebuild All) в меню Проект (Project) либо используйте аналогичную кнопку на панели инструментов (Рис. 4-1) для выполнения проекта

    После успешного создания файла задач можно запустить эмуляцию и отладку программы (см. Главу Меню - Отладка).

    Ассемблирование /Компиляция

    Эта команда используется для компиляции либо ассемблирования исходных файлов с целью проверки на ошибки. Результат выполнения отображается в выходном окне Output.

    Ассемблирование или компиляция программы

    • Используйте меню Файл (File) для выбора исходного файла, который следует скомпилировать ил ассемблировать
    • Выберите команду Ассемблирование/компиляция (Assemble/Compile) меню проект (Project) либо используйте соответствующую кнопку на панели инструментов

      Если выбранный файл имеет расширение .asm, будет запущен Кросс-ассемблер. Если файл имеет расширение .C, будет использован компилятор Holtek C.

    В том случае, если файл не содержит ошибок, в выходной директории, заданной опцией Output Files Path (см. Меню Опции, команда Директории), будет создан объектный файл с расширением.OBJ. Если ошибки в файле присутствуют, в выходном окне Output появится соответствующее сообщение. Переход к строке, вызвавшей ошибку, осуществляется:

    • Двойным щелчком левой кнопкой мыши по сообщению об ошибке
    • Переводом курсора на сообщение об ошибке в выходном окне Output и нажатием клавиши <Enter>

    Печать таблицы опций (Print Option Table)

    Эта команда выводит на принтер текущий активный файл опций. Перед началом печати можно выбрать настройки принтера. Рекомендуется не использовать для принтера порт, к которому подключается эмулятор HT-ICE.

    В случае, если принтер и HT-ICE используют общий параллельный порт, выполнение этой команды приведёт к утере всей отладочной и сопутствующей информации. После завершения печати, если требуется дальнейшая отладка и эмуляция программы, следует начинать процесс с самого начала, используя команду Выполнить (Build) меню Проект (Project).

    Генерация демо-файла (Generate Demo File (.DMO))

    Этой командой генерируется демо-файл (.dmo) для программы HT-DEMO. Пользователь может использовать этот .dmo файл совместно с программой HT-DEMO для демонстрации проекта на ПК без установки пакета HT-IDE3000.



    <-- Предыдущая страница Оглавление Следующая страница -->

        Получить консультации и преобрести компоненты вы сможете у официального дистрибьютора фирмы Holtek Semiconductor компании ChipSelect,






  •  
    Впервые? | Реклама на сайте | О проекте | Карта портала
    тел. редакции: +7 (495) 514 4110. e-mail:info@eust.ru
    ©1998-2016 ООО Рынок Микроэлектроники