В HTML      В PDF
микроэлектроника, микросхема, микроконтроллер, память, msp430, MSP430, Atmel, Maxim, LCD, hd44780, t6963, sed1335, SED1335, mega128, avr, mega128  
  Главная страница > Программы > HT-3000

реклама

 
радиационно стойкие ПЗУ Миландр

Продажа силового и бронированного кабеля и провода в Москве

текст еще



Глава 3. Меню Файл/Правка/Вид/Инструменты/Опции (File/Edit/View/Tools/Options)

В этой главе описаны некоторые пункты меню и команды программы HT-IDE3000. Остальные пункты меню описаны в главах Проект (Project), Отладка (Debug) и Окно (Window).

Запуск системы HT-IDE3000


Рис. 3-1

  • Нажмите кнопку <Пуск> (), выберите <Программы> () и выберите Holtek HT-IDE3000
    • Нажмите на иконку HT-IDE3000
  • Если в последнем проекте, который вы использовали в среде HT-IDE3000, был включен режим эмуляции (использование HT-ICE), то после запуска появится одно из окон, показанных на Рис. 3-2 в том случае, если
    • Нет связи или срыв связи между компьютером и отладчиком HT-ICE
    • Отключено питание отладчика HT-ICE


Рис. 3-2

Если выбрано и связь между HT-ICE и компьютером восстановлена, появится окно, показанное на Рис. 3-3, программа HT-IDE3000 будет работать в режиме эмуляции, отладчик HT-ICE начнёт функционировать.


Рис. 3-3

Если в последнем проекте, который вы использовали в среде HT-IDE3000, был включен режим симуляции (использование Симулятора), то после запуска появится окно, показанное на Рис. 3-4, что означает, что программа HT-IDE3000 работает в режиме симулятора.


Рис. 3-4

В программе HT-IDE3000 существуют 9 пунктов меню - Файл (File), Правка (Edit), Вид (View), Проект (Project), Отладка (Debug), Инструменты (Tools), Опции (Options), Окно (Window) и Помощь (Help). В следующих параграфах будут описаны функции и команды каждого из меню.

Графическая панель инструментов снизу панели меню (Рис. 3-5), содержит иконки, сопоставленные наиболее часто используемым командам меню, что ускоряет и облегчает их использование. Если подвести курсор к иконке, рядом будет высвечено название соответствующей команды. Нажатие на иконку вызывает выполнение соответствующей команды.

Панель состояния внизу окна (Рис. 3-5) отображает текущий статус (эмулятор либо симулятор) и результат выполнения команд. Также в этой панели отображается состояние программного счётчика (PC=0001H) в процессе отладки (Debug).


Рис. 3-5

В панели состояния отображается информация, которая может быть полезна в режиме отладки. Программный счётчик (Program Counter) используется во время выполнения программы и показывает текущее значение Программного Счётчика, индикаторы ряда и строки показывают текущее положение курсора в режиме редактирования программы.

Меню Файл (File)

Меню Файл (File) содержит команды для работы с файлами. Вверху показано соответствие иконок командам, ниже даётся краткое описание команд меню.

  • New Создаёт новый файл
  • Open
    Открывает существующий файл
  • Close
    Закрывает текущий активный файл
  • Save
    Сохраняет данные в текущем активном окне в текущий активный файл
  • Save As ...
    Сохраняет данные в текущем активном окне в выбранный файл
  • Save All
    Сохраняет данные во всех окнах в соответствующие файлы
  • Print
    Выводит данные текущего активного окна на принтер
  • Print Setup
    Настройки принтера
  • Recent Files
    Показывает четыре наиболее часто используемых файла
  • Exit
    Выход из программы HT-IDE3000 и возврат в Windows

Меню Правка (Edit)

  • Undo
    Отменяет предыдущую операцию редактирования
  • Redo
    Отменяет предыдущую операцию Undo
  • Cut
    Удаляет выделенные строки из файла и помещает их в буфер обмена
  • Copy
    Копирует выделенные строки из файла в буфер обмена
  • Paste
    Вставляет информацию из буфера обмена
  • Delete
    Удаляет выделенные данные
  • Find
    Поиск введенного слова в активном буфере редактора
  • Replace
    Заменяет исходное выбранное слово на вновь введенное, в активном буфере редактора

Меню Вид (View)

Меню Вид (View) содержит команды контроля окна программы HT-IDE3000. (см. Рис. 3-6)

  • Line
    Перемещает курсор на выбранную строку (выбирается номер строки) в текущем активном файле
  • Cycle Count
    Производит накопительный подсчёт тактов. Для очистки счётчика нажмите кнопку <Reset>. Переключателем Hex/Dec выбирается десятичное либо шестнадцатеричное счисление. Максимальное число тактов равно 65535.
  • Toolbar
    Показывает в окне Панель управления. Панель управления это группа кнопок, которым сопоставлены соответствующие команды из меню. Если подвести курсор к кнопке, рядом будет высвечено название соответствующей команды. Нажатие на иконку вызывает выполнение команды. Описание функций каждой кнопки описано в соответствующем разделе. Кнопка <Toggle Breakpoint> устанавливает точку останова на текущей строке курсора (строка при этом подсвечивается). Повторное нажатие на кнопку снимает ранее установленную точку останова.
  • Status Bar
    Отображает панель состояния внизу окна.


Рис. 3-6

Меню Инструменты (Tools)

Меню Инструменты (Tools) содержит специальные команды, используемые при отладке пользовательской программы. Список команд включает в себя Опцию Маски (Mask option), Диагностику (Diagnose), Ручную запись (HandyWriter), Управление библиотеками (Library Manager), Редактор голосового ПЗУ (Voice/VROM Editor), Загрузку голоса (Voice/Download), Симулятор ЖКИ (LCD Simulator) и Управление виртуальной периферией (Virtual Peripheral Manager).


Рис. 3-7

Опция маски (Mask option)

При помощи этой команды генерируется файл опций, который используется при Выполнении проекта (Build). Содержимое файла зависит от выбранного типа МК. Эта команда позволяет изменять опции уже после создания проекта.

  • Выбор источника тактирования

    Используемый отладчиком HT-ICE источник тактирования может быть выбран либо при установке опций МК, либо при создании нового проекта, либо при изменении опций. Отладчик HT-ICE может использовать два типа источников тактирования - внутренний и внешний. При выборе внешнего источника следует установить в требуемое положение джампер JP1.

    • Для режима кварцевого резонатора установить кварц на X1 и установить перемычку между точками 2 и 3 джампера JP1 на интерфейсной плате сопряжения.
    • Для режима RC-генератора тактовая частота устанавливается при помощи VR1, при этом следует установить перемычку между точками 1 и 2 джампера JP1 на интерфейсной плате сопряжения.
  • Внутренний источник тактирования

    При использовании внутреннего источника тактирования следует указать частоту, на которой будет работать устройство. Программа HT-IDE3000 вычислит частоту, на которой будет работать отладчик HT-ICE, эта частота будет максимально близкой к указанной. Если вычисленная частота сильно отличается от указанной, на экран будет выведено предупреждение, а так же значения, как для указанной, так и для вычисленной частоты. При этом, для использования вычисленной частоты потребуется дополнительное подтверждение, либо можно выбрать другое значение рабочей частоты. В противном случае можно использовать внешний источник тактирования. Вне зависимости от выбранного источника тактирования следует указать рабочую частоту устройства.

Диагностика (Diagnose)

Эта команда (См. Рис. 3-8) помогает осуществить проверку корректности работы отладчика HT-ICE. Существует 9 диагностируемых параметров. Можно либо выбрать интересующие параметры, установив соответствующую "галочку" и нажав кнопку <Test>, либо диагностировать все параметры, нажав <Test All>. Параметры диагностики приведены ниже.

  • MCU resource option space
    Диагностика опций МК в отладчике HT-ICE.
  • Code space
    Диагностика программного кода в отладчике HT-ICE.
  • Trace space
    Диагностика буфера трассировщика в отладчике HT-ICE.
  • Data space
    Диагностика программной памяти в отладчике HT-ICE.
  • System space
    Диагностика системной памяти в отладчике HT-ICE.
  • I/O EV 0
    Диагностика ввода-вывода (I/O) отладочного (EV) чипа в разъёме 0 отладчика HT-ICE.
  • I/O EV 1
    Диагностика ввода-вывода (I/O) отладочного (EV) чипа в разъёме 1 отладчика HT-ICE
  • I/O EV 2
    Диагностика ввода-вывода (I/O) отладочного (EV) чипа в разъёме 2 отладчика HT-ICE.
  • I/O EV 3
    Диагностика ввода-вывода (I/O) отладочного (EV) чипа в разъёме 3 отладчика HT-ICE.


Рис. 3-8

Ручная запись (HandyWriter)

Команда Ручная запись (HandyWriter) меню Инструменты (Tools) управляет функциями встроенного программатора OTP чипов отладчика HT-ICE либо внешнего отдельного программатора HandyWriter. Обратите внимание, что этой командой не управляется внешний программатор HT-Writer. Дополнительная информация по данному вопросу содержится на веб-сайте фирмы Holtek.

Управление библиотеками (Library Manager)

Команда Управление библиотеками (Library Manager) (Рис. 3-9) содержит функции управления библиотеками. Часто используемые части программного кода могут быть скомпилированы в виде библиотечных файлов и в дальнейшем добавлены в проекты при помощи команды Проект (Project) меню Опции (Options). (См. описание опций Кросс-линкера в меню Опции (Options)). Функции менеджера библиотек включают в себя:

  • Создание нового библиотечного файла или редактирование существующего
  • Добавка программного модуля в библиотечный файл или извлечение из него
  • Выделение программного модуля из библиотечного файла и создание объектного файла

В главе III даётся более подробное описание менеджера библиотек.


Рис. 3-9

Редактор голосового ПЗУ (Voice/VROM Editor)

Редактор голосового ПЗУ (VROM Editor) предназначен для отладки кода голосового ПЗУ, присутствующего в некоторых сериях МК (например, в серии HT86)

Загрузка голоса (Voice/Download)

Эта команда осуществляет загрузку выбранного голосового файла с расширением .VOC в эмулятор HT-ICE для отладки. Также с её помощью можно скопировать содержимое голосовой памяти VROM эмулятора HT-ICE и сохранить его в выбранный .VOC файл. На Рис. 3-10 показано диалоговое окно, где видно имя .VOC файла, сгенерированное Редактором VROM после загрузки данных из памяти. Строка Размер (Size) показывает текущий объём голосового ПЗУ используемого в проекте МК. После загрузки данных из голосовой памяти отладчика HT-ICE имя файла можно изменить. Перед загрузкой данных в память убедитесь, что соответствующий .VOC файл уже сгенерирован Редактором VROM.


Рис. 3-10

Симулятор ЖКИ (LCD Simulator)

Симулятор ЖКИ HT-LCDS позволяет моделировать сигналы с выхода ЖК-драйвера. HT-LCDS отображает состояние экрана в режиме реального времени в соответствии с выбранной конфигурацией и управляющей пользовательской программой. В главе III даётся более подробное описание симулятора ЖКИ.

Управление виртуальной периферией (Virtual Peripheral Manager)

Менеджер виртуальной периферии (VPM) является механизмом моделирования работы периферийных модулей. Он используется в том случае, когда HT-IDE3000 работает в режиме симулятора.

Меню Опции (Options)

Меню Опции (Options) (Рис. 3-11) позволяет выбрать рабочие параметры, используемые командами из других пунктов меню.

Команда Проект (Project)

Команда Проект (Project) устанавливает параметры по умолчанию, используемые командой Выполнить (Build) меню Проект (Project). В процессе разработки опции проекта могут изменяться в зависимости от потребностей. Файл задач, используемый командой Выполнить (Build) меню Проект (Project) генерируется программой HT-IDE3000 в зависимости от установленных опций. Для выбора требуемых опций проекта используется диалоговое окно (Рис. 3-12).

Примечание: Перед осуществлением команды Выполнить (Build), убедитесь, что для проекта установлены корректные опции.


Рис. 3-11


Рис. 3-12

  • Micro Controller
    Тип МК для текущего проекта. Используйте скроллинг в выпадающем окне для выбора требуемого типа.
  • Enter free run mode (debug options disabled) after build
    Выберите эту опцию, если вы хотите, чтобы после загрузки HT-IDE3000 перешёл в режим непрерывной работы. Все отладочные функции в этом режиме запрещены.
  • Cross Assembler options
    Опции командной строк Кросс-ассемблера. Определения для символов позволяют пользователю выбрать значения для этих символов, используемые при ассемблировании программы. Синтаксис выглядит следующим образом:
    symbol1[=value1] [,symbol2 [=value2] [,...]]
    

    например:

    debugflag=1, newver=3
    

    Выбор опции Generate listing file используется для проверки файла листинга исходной программы, который будет сгенерирован в данном случае.

  • Cross Linker options
    Здесь выбираются опции Кросс-линкера. Для определения файлов библиотек, используемых Кросс-линкером, следует указать их названия. Например:
    libfile1, libfile2
    

Файлы библиотек могут быть выбраны непосредственно с помощью кнопки <Browse>. Поле Адрес секции (Section address) используется для указания адресов ПЗУ/ОЗУ для выбранных секций программы, например:

codesec=100, datasec=40

Выбор опции Generate map file используется для проверки файла карты памяти, который будет сгенерирован в данном случае Кросс-линкером.

Команда Отладка (Debug)

Этой командой устанавливаются опции для режима Отладки (Debug) (См. Главу 5 HT-IDE3000 Меню - Отладка (Debug)). Диалоговое окно (Рис. 3-13) демонстрирует все опции отладки, позволяя выбирать их индивидуально. При выборе опции и нажатии кнопки <OK>, в дальнейшем эти опции будут использоваться при отладке через меню Отладка (Debug).


Рис. 3-13

  • Trace Record Fields

    Здесь выбирается, какая информация будет отображаться по команде Листинг Трассировщика (Trace List) , содержащейся в меню Окно (Window). Информация будет отображаться для всех исходных файлов в том порядке, в каком расположены опции в диалоговом окне сверху вниз. Если какая-либо опция не отмечена, будет отображаться следующая выбранная опция. По умолчанию листинг трассировщика состоит только из имени файла и числа строк. Информация об дизассемблированной инструкции (de-assembled instruction) берётся из машинных кодов, а исходная строка берётся из исходного файла. Результат выполнения (execution data) - это прочтённые данные, если выполняется операция чтения, или записанные данные, если выполнялась инструкция записи либо чтения-записи. Статус внешних сигналов (external signal status) не имеет значения, если выбран режим симулятора.

  • Auto Stepping Command

    Выбирает режим при вызове процедуры, Вход в процедуру (Step Into) или Перешагивание (Step Over). Можно выбрать только одну из этих опций.

  • Connection Port

    Выбор параллельного порта компьютера, к которому подключается HT-ICE. Можно выбрать из LPT1, LPT2 или LPT3. Если используется режим симулятора, этот выбор не имеет значения.

  • Mode

    Выбирает рабочий режим программы HT-IDE3000, который может быть режимом эмулятора либо симулятора. Если отладчик HT-ICE подключен к компьютеру и включен, то можно выбрать любой из двух режимов.

  • Detect Stack Overflow

    Уберите "галочку", если вы не хотите получать предупреждений системы при переполнении стека.

Команда Директории (Directories)

Этой командой выбирается путь для поиска по умолчанию и директория для сохранения файлов (Рис. 3-14)


Рис. 3-14

  • Executable files path
    Путь, по которому программа HT-IDE3000 ищет выполняемые файлы при их вызове.
  • Include files path
    Путь, по которому Кросс-ассемблер ищет присоединённые (include) файлы.
  • Library files path
    Путь, по которому Кросс-линкер ищет файлы библиотек.
  • Output files path
    Директория для сохранения выходных файлов Кросс-ассемблера (.obj, .lst) и Кросс-линкера (.tsk, .map, .dbg)

Команда Редактор (Editor)

Этой командой определяются опции Редактора, такие, как размер отступа и счётчик команд Отмена (Undo). Опция Сохранить Перед Ассемблированием (Save Before Assemble) позволяет сохранить файлы пред процедурой ассемблирования. Максимальное число операций отмены (Maximum Undo Count) - максимально возможное число последовательных выполнений операции Отмена (Undo).


Рис. 3-15

Команда Цвет (Color)

Команда определяет цвет фона и выделения для выделенной строки. Опция выбора цвета текста Text Selection (Рис. 3-16) используется для меню Редактирования (Edit), текущей строки, строки с точкой останова, строки трассировки и строки стека меню Отладка (Debug) и для сообщений об ошибках при ассемблировании.


Рис. 3-16

Команда Шрифт (Font)

Этой командой выбираются отображаемые шрифты.



<-- Предыдущая страница Оглавление Следующая страница -->

    Получить консультации и преобрести компоненты вы сможете у официального дистрибьютора фирмы Holtek Semiconductor компании ChipSelect,






 
Впервые? | Реклама на сайте | О проекте | Карта портала
тел. редакции: +7 (495) 514 4110. e-mail:info@eust.ru
©1998-2016 ООО Рынок Микроэлектроники